Device Trust Connectivity Issue
Incident Report for Arculix Public Status Page
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 15:59 UTC
Monitoring
We have identified the issue and made changes to resolve. We will continue to monitor closely.

If you have any questions, please reach out to our Global Support Team at support@secureauth.com or open a case through our portal at https://support.secureauth.com
Thank You.
Posted Apr 30, 2024 - 14:50 UTC
Investigating
We are currently investigating an issue with Device Trust affecting MFA modes. Please use offline codes or password authentication as a work around.
Posted Apr 30, 2024 - 14:19 UTC
This incident affected: Arculix (Arculix Core).